Compile nginx for zimbra

Andrea Soracchi soracchi at
Fri Jul 6 13:48:58 UTC 2012


very strange. This is the output of command: dpkg --list | grep -i sasl:

ii  libsasl2-2                      2.1.23.dfsg1-5ubuntu1             Cyrus SASL - authentication abstraction libr
ii  libsasl2-dev                    2.1.23.dfsg1-5ubuntu1             Cyrus SASL - development files for authentic
ii  libsasl2-modules                2.1.23.dfsg1-5ubuntu1             Cyrus SASL - pluggable authentication module


----- Messaggio originale -----
Da: "Maxim Dounin" <mdounin at>
A: nginx at
Inviato: Venerdì, 6 luglio 2012 15:35:15
Oggetto: Re: Compile nginx for zimbra


On Fri, Jul 06, 2012 at 03:19:08PM +0200, Andrea Soracchi wrote:

> Hi,
> thanks for your help.
> I get this error:
> ./configure: error: the invalid value in --with-ld-opt="-lsasl"
> Idea?

Your ld doesn't like -lsasl options, i.e. you don't have SASL 
library installed, at least not in default library path. 

Maxim Dounin

nginx mailing list
nginx at

More information about the nginx mailing list