Socket leaks., pread and [crit] SSL_Write() in 1.0.14

TECK nginx-forum at
Tue Mar 27 02:28:41 UTC 2012

I mention this because the [crit] issues were present in the past with
Nginx 0.8 and they were solved by Igor. I was hoping a similar fix would
be provided for latest stable version. Do you recommend me to switch to
development version? Upgrading openssl is not a viable solution at the
present time and we are getting a fairly large number of [crit]
SSL_write() errors in our logs.

Posted at Nginx Forum:,224381,224445#msg-224445

More information about the nginx mailing list