install nginx-1.2.4 problems

Jonathan Matthews contact at
Sat Oct 20 11:37:23 UTC 2012

On 20 October 2012 11:33, ahmadtrco <nginx-forum at> wrote:
> When we try to install nginx-1.2.4 and check with. /configure then two
> problems come as fallows:
>   + OpenSSL library is not used
>   + sha1 library is not found
> And then we check openssl installed or not then result come:-
> rpm -qa openssl
> openssl-0.9.8e-22.el5_8.4
> openssl-0.9.8e-22.el5_8.4

I suggest these aren't the -dev packages with headers/source, and
you're just installing runtime binaries which nginx can't use during
compilation. Install the devel packages.


Jonathan Matthews // Oxford, London, UK

More information about the nginx mailing list