Building nginx with TCP_FASTOPEN enabled

mastercan nginx-forum at
Sun Aug 10 11:59:02 UTC 2014

Maxim Dounin Wrote:
> Try looking into objs/autoconf.err, it has details about configure 
> test failures.  Most likely, the TCP_FASTOPEN constant isn't 
> defined since your glibc isn't recent enough, something like 2.18+ 
> is needed.

Yes, you're right. glibc was the problem. I tried to build an nginx deb
package on a development machine with updated glibc libs and installed it on
the production server.
Unfortunately I get this error when trying to start nginx:
"/lib/x86_64-linux-gnu/ version `GLIBC_2.14' not found (required
by /usr/sbin/nginx)"

So I guess I must upgrade glibc on the production server as well...which
might break dependencies...

Posted at Nginx Forum:,252447,252458#msg-252458

More information about the nginx mailing list