undefined symbol ngx_pool_cleanup_file

Stoyan Tzalev stzalev at itdnet.net
Wed Jul 11 18:21:16 MSD 2007

(had to resend this, sorry if you received it twice)

Hi guys,
I'm trying to run a simple auth-against-LDAP module following the idea 
described in Example 2 in http://wiki.codemongers.com/NginxFaq#imapexample
The problem is that when I try to "use nginx;" in my Perl program, it fails 
load '/usr/local/nginx-0.6.2/perl/modules/x86_64-linux-thread-multi/auto/nginx/nginx.so' 
for module 
nginx: /usr/local/nginx-0.6.2/perl/modules/x86_64-linux-thread-multi/auto/nginx/nginx.so: 
undefined symbol: ngx_pool_cleanup_file 
at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/XSLoader.pm line 70.
 at /usr/local/nginx-0.6.2/perl/modules/x86_64-linux-thread-multi/nginx.pm 
line 53"

The system is CentOS5 x86_64, and the same error appears repeatedly with nginx 
0.5.27, 0.6.1 and 0.6.2. built from source with the following configure line:
./configure --prefix=/usr/local/nginx-0.6.2 --with-mail --with-mail_ssl_module --with-http_perl_module --with-perl_modules_path=/usr/local/nginx-0.6.2/perl/modules

I have also tried a pre-built RPM from here: 
with the same negative result.

I'm wondering whether I'm missing something obvious or maybe I hit a bug? 
Thank you very much for your comments.

Best regards,


More information about the nginx mailing list