undefined symbol ngx_pool_cleanup_file

Igor Sysoev is at rambler-co.ru
Wed Jul 11 18:34:48 MSD 2007

On Wed, Jul 11, 2007 at 05:21:16PM +0300, Stoyan Tzalev wrote:

> I'm trying to run a simple auth-against-LDAP module following the idea 
> described in Example 2 in http://wiki.codemongers.com/NginxFaq#imapexample
> The problem is that when I try to "use nginx;" in my Perl program, it fails 
> with:
> "Can't 
> load '/usr/local/nginx-0.6.2/perl/modules/x86_64-linux-thread-multi/auto/nginx/nginx.so' 
> for module 
> nginx: /usr/local/nginx-0.6.2/perl/modules/x86_64-linux-thread-multi/auto/nginx/nginx.so: 
> undefined symbol: ngx_pool_cleanup_file 
> at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/XSLoader.pm line 70.
>  at /usr/local/nginx-0.6.2/perl/modules/x86_64-linux-thread-multi/nginx.pm 
> line 53"
> The system is CentOS5 x86_64, and the same error appears repeatedly with nginx 
> 0.5.27, 0.6.1 and 0.6.2. built from source with the following configure line:
> ./configure --prefix=/usr/local/nginx-0.6.2 --with-mail --with-mail_ssl_module --with-http_perl_module --with-perl_modules_path=/usr/local/nginx-0.6.2/perl/modules
> I have also tried a pre-built RPM from here: 
> http://fr2.rpmfind.net//linux/RPM/fedora/extras/6/x86_64/nginx-0.5.27-1.fc6.x86_64.html 
> with the same negative result.
> I'm wondering whether I'm missing something obvious or maybe I hit a bug? 
> Thank you very much for your comments.

First, although there written "ultrafast nginx based authentifier",
I should advice that while embedded perl execute any SQL query this worker
process does not handle any connection.

As to your problem, do you see the message when you start nginx ?

Igor Sysoev

More information about the nginx mailing list