Can not configure pcre on CENTOS

Igor Sysoev igor at
Tue Nov 24 18:55:00 MSK 2009

On Tue, Nov 24, 2009 at 10:36:04AM -0500, johndesp wrote:

> Hi.  I apologize but I am a linux noobie.  I installed pcre on Centos using  "yum install pcre-devel" .   Everything worked fine. However, I can seem to find the correct location for the pcre library.  I use locate and find and have tried several combinations.
> The following is my configure command:
> /configure --sbin-path=/sbin/nginx --conf-path=/usr/local/nginx/nginx.conf --pid-path=/usr/local/nginx/ --with-http_ssl_module --with-md5=auto/lib/md5 --with-sha1=auto/lib/sha1 --with-http_perl_module --without-http_rewrite_module --with-pcre=../pcre-6-6.2
> ./configure runs fine.
> make fails
> I have tried several different values for the --with-pcre= option, such as /usr/bin/pcre-6-6.2 and I always get the following
> Entering directory `/tmp/nginx/nginx-0.7.64'
> cd ../pcre-6-6.2 \
> 	&& if [ -f Makefile ]; then make distclean; fi \
> 	&& CC="gcc" CFLAGS="-O2 -fomit-frame-pointer -pipe " \
> 	./configure --disable-shared
> /bin/sh: line 0: cd: ../pcre-6-6.2: No such file or directory
> make[1]: *** [../pcre-6-6.2/Makefile] Error 1
> make[1]: Leaving directory `/tmp/nginx/nginx-0.7.64'
> make: ***  Error 2
> How can I locate the correct library for pcre and what value should I set it to for the --with-pcre option?

If your have installed PCRE using package manager, you do not need
--whit-pcre= at all: configure should find installed pcre by itself.

Igor Sysoev

More information about the nginx mailing list