Can not configure pcre on CENTOS

Maxim Dounin mdounin at
Tue Nov 24 19:04:39 MSK 2009


On Tue, Nov 24, 2009 at 10:36:04AM -0500, johndesp wrote:

> Hi.  I apologize but I am a linux noobie.  I installed pcre on Centos using  "yum install pcre-devel" .   Everything worked fine. However, I can seem to find the correct location for the pcre library.  I use locate and find and have tried several combinations.
> The following is my configure command:
> /configure --sbin-path=/sbin/nginx --conf-path=/usr/local/nginx/nginx.conf --pid-path=/usr/local/nginx/ --with-http_ssl_module --with-md5=auto/lib/md5 --with-sha1=auto/lib/sha1 --with-http_perl_module --without-http_rewrite_module --with-pcre=../pcre-6-6.2

You should remove the following arguments from ./configure:


They should be used specify path to *sources* of appropriate 
libraries and your usage is obviously wrong.  As soon as libraries 
in question are installed on your system nginx will be able to 
find them.

For more information see:

./configure --help

Maxim Dounin

More information about the nginx mailing list