uWSGI & pylons URL problem

Roberto De Ioris roberto at unbit.it
Tue Aug 3 18:28:59 MSD 2010

Il giorno 03/ago/2010, alle ore 16.11, timeu ha scritto:

> Hi all 
> I tried to setup nginx with the uwgsi module to a pylons application
> which runs via the uWGSI Server according to following tutorial:
> http://tonylandis.com/python/deployment-howt-pylons-nginx-and-uwsgi/
> However when i try to access the pylons application all links which were
> created with the pylon's url object are messed up (double slash "//" at
> the beginning instead of one slash "/")
> If i use following code to generate the url for the current pylons
> "page":
> [code]
> ${h.url.current()}
> [/code]
> I get "//CURRENT_URL" instead of "/CURRENT_URL"
> I tried it even with a fresh pylons app, to make sure that none of my
> routing entries are responsible for this behavior.
> It seems that the SCRIPT_NAME "/" is added at the beginning of each URL
> somehow. 

This is an issue signalled by Andrey Petrov and fixed in the current mercurial repository (you can check it in the mailing list archive).

I hope to release a maintainance version of the 0.9.5 tree asap.

Roberto De Ioris
JID: roberto at jabber.unbit.it

More information about the nginx mailing list