uWSGI & pylons URL problem

timeu nginx-forum at nginx.us
Tue Aug 3 18:11:36 MSD 2010

Hi all 

I tried to setup nginx with the uwgsi module to a pylons application
which runs via the uWGSI Server according to following tutorial:

However when i try to access the pylons application all links which were
created with the pylon's url object are messed up (double slash "//" at
the beginning instead of one slash "/")

If i use following code to generate the url for the current pylons

I get "//CURRENT_URL" instead of "/CURRENT_URL"

I tried it even with a fresh pylons app, to make sure that none of my
routing entries are responsible for this behavior.
It seems that the SCRIPT_NAME "/" is added at the beginning of each URL

I don't think my problem is related to the uWSGI Server because when i
try to access the uWSGI served pylons app via Cherokee the links are

I would be thankful for any ideas or hints. 

I used following versions:

nginx: 0.8.47-0
pylons: 1.0 (but same problem with 0.9.7)

Thanks in advance

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,116092,116092#msg-116092

More information about the nginx mailing list