How come nginx is only accepting 1 connection?

Roberto De Ioris roberto at
Tue Jan 18 19:33:00 MSK 2011

Il giorno 18/gen/2011, alle ore 17.23, He Shiming ha scritto:

> 2011/1/18 Maxim Dounin <mdounin at>:
>> Hello!
>> There are no settings in nginx which may cause such behaviour
>> (well, problems may happen with "sendfile on;" without
>> sendfile_max_chunk set while sending huge files over fast links -
>> due to blocking in sendfile() syscall, but it's not your case).
>> This may be problem in track_uploads module though, it's third party
>> one and I have no idea about it's bugs.
>> You may test the following:
>> 1. If requesting normal static file (or just sending an invalid
>> request) works.
>> 2. If doing the same with track_uploads disabled works.
>> Maxim Dounin
> UWSGI is like this: uwsgi --paste
> config:/pylonsenv/ajaxupload/production.ini --socket
> /pylonsenv/ajaxupload/uwsgi.socket -H /pylonsenv -p 10
> I tried disabling the upload progress module. I even tried upgrading
> to nginx 0.9.3, disabling all modules during compiling. Nothing works.
> -

Are you sure you are not running pylons with debug enabled ?

It can cause some problems with multiprocess apps

Roberto De Ioris

More information about the nginx mailing list