Error: This server's certificate chain is incomplete.

Peter Fraser petros.fraser at
Tue Dec 30 21:18:03 UTC 2014

Thanks for that. I found out also that I need to export all the
intermediate certs. I used this command below to export them all to a text
openssl pkcs12 -in <file_name>.pfx -out outputfile.txt -nodes.

Then I manually removed the private key and used the result as the cert. It
works now except that the same test result says "Contains Anchor" This is
not really a problem from what I have read but I will spend a little time
trying to figure how to correct this also.

On Tue, Dec 30, 2014 at 2:38 PM, Scott Larson <stl at> wrote:

>      That test should point you in some direction but you're probably
> missing an intermediate certificate which would normally be provided by the
> issuer and appended to the file containing your server certificate.
> *__________________Scott LarsonSystems AdministratorWiredrive/LA310 823
> 8238 ext. 1106310 943 2078
> <>
> <>
> <>*
> On Tue, Dec 30, 2014 at 11:34 AM, Peter Fraser <petros.fraser at>
> wrote:
>> Hi All
>> I managed to get the nginx reverse proxy up and forwarding to my https
>> web server.
>> I think I have missed something though as a user just let me know that
>> when he tried to access the site he gets a message that the certificate is
>> invalid.
>> I just did a test with ssllabs and noticed that it shows this error:
>> "This server's certificate chain is incomplete. "
>> Any ideas on what I have missed? Thanks for the assistance.
>> Regards.
>> _______________________________________________
>> nginx mailing list
>> nginx at
> _______________________________________________
> nginx mailing list
> nginx at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the nginx mailing list