Alias or rewrite to get Horde rpc.php to work

m1nu2 nginx-forum at
Wed Jun 25 08:09:50 UTC 2014

m1nu2 Wrote:
> Hello all,
> I'm trying to setup a nginx server on a RaspberryPi to host a Horde
> Groupware. The Webinterface is working so far. But I have problems
> setting up the Microsoft-Server-ActiveSync URL to sync my Smartphone
> and Tablet. I already asked in the IRC channel and posted a question
> at Serverfault but did not get an answer yet. I also googled a lot,
> tried different solutions, but non of these worked. So I would be
> really happy if someone could help me with that. Here are more details
> (mainly taken from the Serverfault question located here:
> de-groupware-activesync-url-does-not-process-the-r ):
> The configuration should allow to access the ActiveSync part via the
> URL /horde/Microsoft-Server-ActiveSync. The horde webinterface is
> already accessible via /horde
> My configuration looks like this:
> default-ssl.conf:
> server {
>         listen                  443 ssl;
>         ssl                     on;
>         ssl_certificate         /opt/nginx/conf/certs/server.crt;
>         ssl_certificate_key     /opt/nginx/conf/certs/server.key;
>         server_name   ;
>         index                   index.html index.php;
>         root                    /var/www;
>         include sites-available/horde.conf;
> }
> horde.conf:
> location /horde {
>         rewrite_log on;
>         rewrite ^/horde/Microsoft-Server-ActiveSync(.*)$
> /horde/rpc.php$1 last;
>         try_files $uri $uri/ /rampage.php?$args;
>         location ~ \.php$ {
>                 try_files $uri =404;
>                 include sites-available/horde.fcgi-php.conf;
>         }
> }.
> horde.fcgi-php.conf:
> include fastcgi_params;
> fastcgi_split_path_info ^(.+\.php)(/.+)$;
> fastcgi_param PATH_INFO $fastcgi_path_info;
> fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info;
> fastcgi_pass unix:/var/run/php5-fpm.sock;
> fastcgi_index index.php;
> fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
> So why is the rpc.php not correctly working? 
> If I understand correctly it tries to establish a basic authentication
> process.
> Could this be a problem?
> Best regards,
> m1nu2

I copy my answer from serverfault here just from completeness:

After more trying and looking at logs (finally the right ones) I found my
fault. After all it was a configuration error.

The Horde Wiki gives the hint in one single line:

    To activate the server, it needs to be enabled in Horde's configuration,
on the ActiveSync tab.

This one gives me the right direction: I searched in the configuration but
could not found the ActiveSync stuff. So I digged deeper and ended up with
the awareness that I did not install the library Horder_ActiveSync. :(

After doing a sudo pear install horde/horde_activesync and updating the
database tables from the WebUI everything works now!

Hope this helps someone else.

Posted at Nginx Forum:,250907,251144#msg-251144

More information about the nginx mailing list