nginx-rtmp-compile-for-windows error??? help

Maxim Dounin mdounin at
Mon Sep 21 12:11:47 UTC 2015


On Sat, Sep 19, 2015 at 12:12:57PM -0400, gdarceneaux wrote:

> Alright. It compiles fine w/o RTMP module and no need for OpenSSL. I have
> NASM, and it's in my path. I still get the same error mentioned because when
> nginx begins it's compile it's trying to do the ms\do_ms.bat instead of the
> ms\do_nasm.bat. I have looked at various files till I can't see straight and
> do not know which files to change to make it point to ms\do_nasm.bat to
> process the assembly language modules. Any help will be appreciated.

As of OpenSSL 1.0.2, OpenSSL fails to compile on Windows using a 
procedure nginx uses (and the one used to be the default for 

The build process used by the --with-openssl configure option was 
adjusted to work around this in nginx 1.9.4, see here:

Please upgrade to a latest nginx version, it should help.  
Alternatively, you can compile OpenSSL yourself instead of asking 
nginx to do this.

Maxim Dounin

More information about the nginx mailing list